Resolved RCE in SG UTM WebAdmin (CVE-2020-25223)

Zurück zur Übersicht der Sicherheitshinweise
Critical
CVE(s)
CVE-2020-25223
Updated:
Produkt(e)
SG UTM
Veröffentlichungs-ID sophos-sa-20200918-sg-webadmin-rce
Artikelversion 2
Erstveröffentlichung
Provisorische Lösung Yes

Overview

A remote code execution vulnerability in the WebAdmin of SG UTM was discovered and responsibly disclosed to Sophos in 2020. It was reported via the Sophos bug bounty program by an external security researcher. The vulnerability was fixed in September 2020.

Devices that have not been updated in the last year and still have WebAdmin exposed to the WAN are vulnerable. Check this Knowledge Base Article for additional information to determine if a device has been compromised and how to remediate.

Applies to the following Sophos product(s) and version(s)

  • Sophos SG UTM

Remediation

  • Fix included in SG UTM v9.705 MR5, v9.607 MR7, and v9.511 MR11 on September 17, 2020
  • Users of older versions of SG UTM are required to upgrade to receive this fix
  • Additionally, Sophos recommends that SG UTM customers upgrade to the latest available release

Workaround

Customers can protect themselves by ensuring their WebAdmin is not exposed to WAN.

This can be achieved by keeping Internal (LAN) (Network) or another internal-only network definition as the sole entry in Management→WebAdmin Settings→WebAdmin Access Configuration→Allowed Networks.

Related information