SafeGuard Client 6.00.1: Installation and Upgrade

  • ID dell'articolo: 118085
  • Aggiornato: 06 gen 2014

Issue

Installation/Upgrade of the SafeGuard Client, version 6.00.1

First seen in

SafeGuard Easy 6.00.1
SafeGuard  Device Encryption 6.00.1
SafeGuard  Configuration Protection 6.00.1

What To Do

Depending on the current installation base and which modules you require, follow one of the below mentioned scenarios. Installations and upgrades on endpoints, including the Configuration Protection module or FIPS compliant mode, require the installation of additional vcredist packages from Microsoft.  

Before installing or upgrading the SafeGuard Client, we recommend you ensure that your system is correctly prepared, as outlined in KBA 108088.

New installations

Default installation (optionally including Data Exchange, Cloud Storage or File Share module)

Follow the steps described in chapter 9.5 "Installing the encryption software" of the SafeGuard Installation Guide.

Installations including the Configuration Protection module

  1. Run the SGxClientPreinstall.msi which is provided together with the Client installers (make sure you´re using the SGxClientPreinstall.msi that comes with SafeGuard 6.00.1 and not a previous version).
  2. Run the VCRedist32 (vcredist_x86_8.0.50727.6195.exe) - required on 32 and 64Bit OS (available in the "3rd party" folder of the SafeGuard product delivery). 
  3. Run the VCRedist64 (vcredist_x64_8.0.50727.6195.exe) - only required on 64Bit OS (available in the "3rd party" folder of the SafeGuard product delivery).
  4. Run the installation of SafeGuard Client including the Configuration Protection module (using SGNClient.msi or SGNClient_x64.msi).
  5. Run the installation of the Configuration Protection Client (using SGNCPClient.msi or SGNCPClient_x64.msi).
  6. Run the installation of the SafeGuard Client Configuration Package (needs to be created in the SafeGuard Management Center, as described in chapter 9.4 of the Installation Manual).
  7. Reboot.

 

FIPS compliant installations

Important: An administrative installation of the SafeGuard Client package (using msiexec /a) in combination with the FIPS_AES parameter is not supported. The resulting installation would not contain the FIPS-certified components.
An already extracted and patched version of the Client package, that contains the required FIPS components, is available on request (contact support@sophos.com for further information).

  1. Run the SGxClientPreinstall.msi which is provided together with the Client installers (make sure you´re using the SGxClientPreinstall.msi that comes with SafeGuard 6.00.1 and not a previous version).
  2. Run the VCRedist32 (vcredist_x86_8.0.50727.6195.exe) - required on 32 and 64Bit OS (available in the "3rd party" folder of the SafeGuard product delivery).
  3. Run the VCRedist64 (vcredist_x64_8.0.50727.6195.exe) - only required on 64Bit OS (available in the "3rd party" folder of the SafeGuard product delivery)
  4. Run the installation of SafeGuard Client in the FIPS compliant mode (using SGNClient.msi or SGNClient_x64.msi in combination with the FIPS_AES parameter e.g. msiexec /i SGNClient.msi FIPS_AES=1 )
  5. Run the installation of the SafeGuard Client Configuration Package (needs to be created in the SafeGuard Management Center, as described in chapter 9.4 of the Installation Manual).
  6. Reboot.


Upgrade of existing installations

Important note: Do Not remove SGxClientPreinstall or VC++ Redist packages that are already installed.

Default installation (optionally including Data Exchange, Cloud Storage or File Share module)

Follow the steps described in chapter 13.4 "Upgrade endpoints" of the SafeGuard Installation Guide.

 

Upgrades from version 5.x including the Configuration Protection module

  1. Run the SGxClientPreinstall.msi which is provided together with the Client installers (make sure you´re using the SGxClientPreinstall.msi that comes with SafeGuard 6.00.1 and not a previous version).
  2. Run the VCRedist32 (vcredist_x86_8.0.50727.6195.exe) - required on 32 and 64Bit OS (available in the "3rd party" folder of the SafeGuard product delivery).
  3. Run the VCRedist64 (vcredist_x64_8.0.50727.6195.exe) - only required on 64Bit OS (available in the "3rd party" folder of the SafeGuard product delivery).
  4. Run the upgrade of the SafeGuard Client including the Configuration Protection module (e.g.: using SGNClient.msi or SGNClient_x64.msi).
  5. Do not reboot.
  6. Remove the SafeGuard Configuration Protection Client.
  7. Reboot the computer.
  8. Install the new SafeGuard Configuration Protection Client (using SGNCPClient.msi or SGNCPClient_x64.msi).
  9. Reboot the computer.

Upgrades from version 6.00.0 including the Configuration Protection module

  1. Run the SGxClientPreinstall.msi which is provided together with the Client installers (make sure you´re using the SGxClientPreinstall.msi that comes with SafeGuard 6.00.1 and not a previous version).
  2. Run the VCRedist32 (vcredist_x86_8.0.50727.6195.exe) - required on 32 and 64Bit OS (available in the "3rd party" folder of the SafeGuard product delivery).
  3. Run the VCRedist64 (vcredist_x64_8.0.50727.6195.exe) - only required on 64Bit OS (available in the "3rd party" folder of the SafeGuard product delivery).
  4. Run the upgrade of the SafeGuard Client including the Configuration Protection module (e.g.: using SGNClient.msi or SGNClient_x64.msi).
  5. Run the upgrade of the SafeGuard Configuration Protection Client (using SGNCPClient.msi or SGNCPClient_x64.msi).
  6. Download, extract and run the PostUpgradeCPClient.zip on the Client
  7. Reboot the computer.


FIPS compliant installation (assuming the Client was installed as FIPS compliant before) 

Important: An administrative installation of the SafeGuard Client package (using msiexec /a) in combination with the FIPS_AES parameter is not supported. The resulting installation would not contain the FIPS-certified components.
An already extracted and patched version of the Client package, that contains the required FIPS components, is available on request (contact support@sophos.com for further information).

  1. Run the SGxClientPreinstall.msi which is provided together with the Client installers (make sure you´re using the SGxClientPreinstall.msi that comes with SafeGuard 6.00.1 and not a previous version).
  2. Run the VCRedist32 (vcredist_x86_8.0.50727.6195.exe) - required on 32 and 64Bit OS (available in the "3rd party" folder of the SafeGuard product delivery).
  3. Run the VCRedist64 (vcredist_x64_8.0.50727.6195.exe) - only required on 64Bit OS (available in the "3rd party" folder of the SafeGuard product delivery).
  4. Run the upgrade of the SafeGuard Client in FIPS compliant mode (using SGNClient.msi or SGNClient_x64.msi in combination with the FIPS_AES parameter e.g. msiexec /i SGNClient.msi FIPS_AES=1 ).
  5. Reboot.

 

 
Per maggiori informazioni o per assistenza, vi preghiamo di contattare il supporto tecnico.

Valutate l'articolo

Molto scadente Eccellente

Commenti