Diffère de la stratégie - Stratégie de contrôle des applications

  • ID de l'article 113072
  • Mis à jour : 15 avr. 2011

Problème
Un ou plusieurs clients signalent à l'Enterprise Console qu'ils "diffèrent de la stratégie". Ceci apparaît dans l'onglet "Contrôle des applications" | colonne "Stratégie de contrôle des applications".

Connu pour s'appliquer au ou aux produits et à la ou aux versions Sophos suivantes

Enterprise Console

Cause
Il y a un ou plusieurs éléments dans le gestionnaire de quarantaine local.  Ces éléments empêchent l'application de la stratégie de contrôle des applications.

Action à mener

Confirmer que le client s'est récemment signalé à la console

Au départ, il est important de confirmer que le client a bien envoyé récemment un message au serveur d'administration Sophos.  Si le client ne s'est pas récemment signalé à la console, l'avertissement n'est peut-être pas précis.

  1. Cliquez avec le bouton droit de la souris sur l'ordinateur dans la console.
  2. Sélectionnez 'Voir les détails de l'ordinateur'.
  3. Dans les fenêtres des détails de l'ordinateur, recherchez la ligne "Dernier message reçu de l'ordinateur".
  4. Si le client est en marche et connecté au réseau, assurez-vous que la date et l'heure figurent dans les dernières 30 minutes.  Si la date et/ou l'heure est en dehors de cette période, vous devez chercher à savoir pourquoi le client ne se signale pas à la console.

Forcer le client à se conformer

Si le serveur a reçu un message récent du client, vous tentez de forcer le client à se conformer.  Ceci annule tous les changements locaux qu'un administrateur peut avoir effectué dans la configuration du client.

  1. Assurez-vous que le ou les clients apparaissent comme connectés dans la console.   Pour ce faire : dans la zone déroulante "Affichage :", sélectionnez "Ordinateurs connectés".
  2. Cliquez avec le bouton droit de la souris sur le client et sélectionnez "Mettre en conformité avec" > "Stratégie de contrôle des applications du groupe".

AVERTISSEMENT : forcer des clients déconnectés à se mettre en conformité va générer une accumulation de messages dans le dossier des enveloppes du serveur d'administration car ces messages ne peuvent pas être envoyés aux clients hors ligne.

Redémarrer le client

Parfois, tant qu'il n'a pas fait l'objet d'un redémarrage, le client peut avoir des problèmes pour se conformer à la configuration en cours.  Ceci est particulièrement vrai si le client vient de faire l'objet d'une mise à niveau.  Si vous ne l'avez pas encore fait, redémarrez un client et attendez que ce dernier se signale (voir la section Confirmer que le client s'est récemment signalé à la console plus haut).

Effacer le gestionnaire de quarantaine du client local

  1. Arrêtez le service Sophos Anti-Virus (Démarrer | Exécuter | Tapez : services.msc | Appuyez sur Entrée).
  2. Supprimez le fichier quarantine.xml depuis : %allusersprofile%\Application Data\Sophos\Sophos Anti-Virus\Config\Quarantine.xml.
  3. Démarrez le service Sophos Anti-Virus.
  4. Depuis la console, forcez une mise en conformité de la stratégie de contrôle des applications sur le client.

Journalisation supplémentaire

Si les étapes ci-dessus ne parviennent pas à résoudre le problème de différence de stratégie, veuillez suivre les étapes ci-dessous :

  1. Journalisation détaillée de l'agent activée sur le client :
    1. Démarrez le service 'Sophos Agent'
    2. Ouvrez l'Editeur de registre Pour plus d'informations, reportez-vous à l'Editeur de registre.
    3. Naviguez vers HKEY_LOCAL_MACHINE\software\[Wow6432Node]\Sophos\Remote Management System\ManagementAgent.
    4. Créez une nouvelle valeur DWORD nommé 'LogLevel'.
    5. Choisissez 2 pour sa valeur.
    6. Redémarrez le service 'Sophos Agent'
  2. Depuis la console, forcez une mise en conformité de la stratégie de contrôle des applications sur le client.
  3. Autorisez le client à se signaler/différer de la stratégie.
  4. Exécutez le Sophos Diagnostic Utility (SDU) sur le client et transférez le fichier résultat.  Pour plus d'informations sur le programme SDU, veuillez consulter l'article : Sophos Diagnostic Utility (SDU) : comment télécharger et installer

 
Si vous avez besoin de plus d'informations ou d'instructions, veuillez contacter le support technique.

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