Microsoft security patch required before installing SafeGuard Enterprise v. 5.50

  • N.º del artículo: 110589
  • Actualizado: 05 may 2010
Issue
A security issue has been identified by Microsoft that could allow an attacker to compromise Windows-based systems with Microsoft Visual C++ 2005 Redistributable Package Service Pack 1 and gain complete control over it.

THIS IS NOT A SAFEGUARD ENTERPRISE SPECIFIC ISSUE!

If you attempt to install SafeGuard Enterprise 5.50 without the SGxClientPreinstall.msi package installed, you will be prompted with the following error message:

This setup requires an installed version 8.0.59193 of the Microsoft C++ Runtime Library. Please preinstall either VCredist_x86.exe or SGxClientPreInstall.msi, both of which can be found in the Install folder of the product DVD.

Known to apply to the following Sophos product(s) and version(s)
SafeGuard Enterprise 5.50

Operating System

Windows XP SP2, SP3, Windows Vista SP2, Windows 7

What To Do

Before installing SafeGuard Enterprise v. 5.50, you must install either VCredist_x86.exe or SGxClientPreInstall.msi, both of which can be found in the Install folder of the product DVD

The SGxClientPreinstall.msi will work on both installs x32 or x64 of the SGN versions.

Background information
Based on the fact that SafeGuard Enterprise (SGN) 5.50 was created within a secure and up-to-date environment containing this Microsoft security patch, the SafeGuard Enterprise installation requires the libraries that were patched with the Microsoft security patch to be present on the client as well. So to insure complete security with the SGN installation, the SGxClientPreinstall.msi which contains the Microsoft patch is needed as a prerequisite for the installation of SGN 5.50.



 
Si necesita más ayuda, póngase en contacto con soporte técnico.

Valore el artículo

Muy malo Excelente

Comentarios