MS14-011 - Vulnerability in VBScript Scripting Engine Could Allow Remote Code Execution (2928390)

Click any highlighted term for further explanation. For more information, contact technical support.

 

Details
Vulnerability name/brief description MS14-011 - Vulnerability in VBScript Scripting Engine Could Allow Remote Code Execution (2928390)
CVE/CAN name
Vendor threat level Critical
SophosLabs threat level High
Solution MS14-011
Vendor description This security update resolves a privately reported vulnerability in the VBScript scripting engine in Microsoft Windows. The vulnerability could allow remote code execution if a user visited a specially crafted website. An attacker would have no way to force users to visit the website. Instead, an attacker would have to convince users to take action, typically by getting them to click a link in an email message or Instant Messenger message that takes users to the attacker's website.
SophosLabs comments Although these vulnerabilities were privately reported and no exploits have been seen as yet, as these vulnerabilities have a major impact on VBScript & IE, SophosLabs actively encourages users to apply this patch as soon as it is available.
SophosLabs testing result No SophosLabs testing result found
Currently known exploits No currently known exploits found
First sample seen No samples found
Discovery date 11 Feb 2014
Affected software VBScript 5.6
Windows XP Professional x64 Edition Service Pack 2 VBScript 5.6 
Windows Server 2003 Service Pack 2 VBScript 5.6 
Windows Server 2003 x64 Edition Service Pack 2 VBScript 5.6 
Windows Server 2003 with SP2 for Itanium-based Systems VBScript 5.6 
VBScript 5.7
Windows XP Service Pack 3 VBScript 5.7 
Windows XP Professional x64 Edition Service Pack 2 VBScript 5.7 
Windows Server 2003 Service Pack 2 VBScript 5.7 
Windows Server 2003 x64 Edition Service Pack 2 VBScript 5.7 
Windows Server 2003 with SP2 for Itanium-based Systems VBScript 5.7 
Windows Vista Service Pack 2 VBScript 5.7 
Windows Vista x64 Edition Service Pack 2 VBScript 5.7 
Windows Server 2008 for 32-bit Systems Service Pack 2 VBScript 5.7 
Windows Server 2008 for x64-based Systems Service Pack 2 VBScript 5.7 
Windows Server 2008 for Itanium-based Systems Service Pack 2 VBScript 5.7 
VBScript 5.8 (Internet Explorer 8)
Windows XP Service Pack 3 VBScript 5.8 
Windows XP Professional x64 Edition Service Pack 2 VBScript 5.8 
Windows Server 2003 Service Pack 2 VBScript 5.8 
Windows Server 2003 x64 Edition Service Pack 2 VBScript 5.8 
Windows Vista Service Pack 2 VBScript 5.8 
Windows Vista x64 Edition Service Pack 2 VBScript 5.8 
Windows Server 2008 for 32-bit Systems Service Pack 2 VBScript 5.8 
Windows Server 2008 for x64-based Systems Service Pack 2 VBScript 5.8 
Windows 7 for 32-bit Systems Service Pack 1 VBScript 5.8 
Windows 7 for x64-based Systems Service Pack 1 VBScript 5.8 
Windows Server 2008 R2 for x64-based Systems Service Pack 1 VBScript 5.8 
Windows Server 2008 R2 for Itanium-based Systems Service Pack 1 VBScript 5.8 
VBScript 5.8 (Internet Explorer 9)
Windows Vista Service Pack 2 VBScript 5.8
Windows Vista x64 Edition Service Pack 2
Windows Server 2008 for 32-bit Systems Service Pack 2 VBScript 5.8
Windows Server 2008 for x64-based Systems Service Pack 2 VBScript 5.8
Windows 7 for 32-bit Systems Service Pack 1 VBScript 5.8
Windows 7 for x64-based Systems Service Pack 1 VBScript 5.8
Windows Server 2008 R2 for x64-based Systems Service Pack 1 VBScript 5.8
VBScript 5.8 (Internet Explorer 10)
Windows 7 for 32-bit Systems Service Pack 1 VBScript 5.8 
Windows 7 for x64-based Systems Service Pack 1 VBScript 5.8 
Windows Server 2008 R2 for x64-based Systems Service Pack 1 VBScript 5.8 
Windows 8 for 32-bit Systems VBScript 5.8 
Windows 8 for x64-based Systems VBScript 5.8 
Windows Server 2012 VBScript 5.8 
Windows RT VBScript 5.8 
VBScript 5.8 (Internet Explorer 11)
Windows 7 for 32-bit Systems Service Pack 1 VBScript 5.8 
Windows 7 for x64-based Systems Service Pack 1 VBScript 5.8 
Windows Server 2008 R2 for x64-based Systems Service Pack 1 VBScript 5.8 
Windows 8.1 for 32-bit Systems VBScript 5.8 
Windows 8.1 for x64-based Systems VBScript 5.8 
Windows Server 2012 R2 VBScript 5.8 
Windows RT 8.1 VBScript 5.8 
Server Core installation
Windows Server 2008 for 32-bit Systems Service Pack 2 (Server Core installation) VBScript 5.7 
Windows Server 2008 for x64-based Systems Service Pack 2 (Server Core installation) VBScript 5.7 
Windows Server 2008 R2 for x64-based Systems Service Pack 1 (Server Core installation) VBScript 5.8 
Windows Server 2012 (Server Core installation) VBScript 5.8 
Windows Server 2012 R2 (Server Core installation) VBScript 5.8 
References
Credits
  • MAPP
Revisions
  • February 11, 2014 - Initial Revision Written

Explanation of terms

Vulnerability Name/Brief Description:

Vendor identifier plus a brief description of the type of attack.

CVE/CAN Name:

Currently assigned CVE name. If a CVE name doesn't exist the CAN name will be used until a CVE has been assigned.

Vendor Threat Level:

Threat level assigned by the vendor

SophosLabs Threat Level:

Threat level assigned by SophosLabs

  • LOW RISK - There is little chance of this vulnerability being actively exploited by malware.
  • MEDIUM RISK - There is a possibility of this vulnerability being actively exploited by malware.
  • HIGH RISK - There is a strong possibility of this vulnerability being actively exploited by malware.
  • CRITICAL RISK - This vulnerability will almost certainly be actively exploited by malware.

Solution:

Vendor-supplied Patch identifier and recommended solution, or workaround if applicable.

Vendor Description:

Summary of the cause and potential effect of the vulnerability provided by the vendor.

SophosLabs Comments:

SophosLabs' opinions and observations of the vulnerability in question.

SophosLabs Testing Result:

Details of completed lab testing, if applicable. Please note that the lab test environment may differ significantly from user environments.

Currently Known Exploits:

List of identities for known exploits, if applicable.

First Sample Seen:

Date of the first sample seen by SophosLabs.

Discovery Date:

Date of the earliest known publically disclosed advisory.

Affected Software:

Vulnerable platforms and software versions.