PureMessage for Unix: pmx-setup does not offer upgrade to PureMessage 6

  • Article ID: 116667
  • Updated: 29 Jan 2014

Issue

When attempting to upgrade a PureMessage version 5 installation to PureMessage 6, the installer may not prompt for the installation of PureMessage 6 as expected.  The following error may also occur:

Error while checking for update to pmx-setup:
While verifying package 'pmx-setup': Package 'pmx-setup' has not been installed by PPM

First seen in

PureMessage for Unix

Cause

This error can occur because the pmx-setup package has been removed via ppm, or the ppm package list is corrupt.

What To Do

Run the following command (as the root user) to upgrade the pmx-setup utility:
/opt/pmx/bin/pmx-setup --upgrade pmx-setup

When prompted, type 'yes' to upgrade pmx-setup.  After upgrading pmx-setup, run the utility again (as the root user):
/opt/pmx/bin/pmx-setup

You should now be prompted to install PureMessage version 6.  Continue the installation as per the PureMessage 6 upgrade guide:
http://pmdocs.sophos.com/pmdocs/Latest/guides/UpgradePureMessageUnix.pdf

 
If you need more information or guidance, then please contact technical support.

Rate this article

Very poor Excellent

Comments