Microsoft Exchange Frontend Transport service fails to start after applying Exchange 2013 SP1

  • Article ID: 120693
  • Updated: 06 Mar 2014

Issue

After applying Exchange 2013 Service Pack 1 to an Exchange server running PureMessage for Microsoft Exchange, the below errors are seen.

When attempting to start the Microsoft Exchange Frontend Transport service in the Services MMC:

Windows could not start the Microsoft Exchange Frontend Transport service on Local Computer. Error 1067 The process terminated unexpectedly.

Application Event Log:

Event ID: 1052 Error: Failed to create agent factory for the agent "PmE15Protocol'

Event ID: 16023 Error: Microsoft Exchange couldn't start transport agents. The Microsoft Exchange Transport service will be stopped.

System Event Log:

Event ID: 7031 Error: The Microsoft Exchange Frontend Transport service terminated unexpectedly.

First seen in

PureMessage for Microsoft Exchange 4.0.1
PureMessage for Microsoft Exchange 4.0

Cause

This has been identified as a Microsoft issue introduced in Exchange 2013 Service Pack 1. This issue has also impacted a number of other vendors.

What To Do

Run the Microsoft PowerShell script

Microsoft have now released a PowerShell script to resolve this issue.

  1. Run the PowerShell script from the Third-party transport agents cannot be loaded correctly in Exchange Server 2013 article, either directly or by using the 'Fix it for me' option
  2. Restart the Microsoft Exchange Transport service
  3. Start the Microsoft Exchange Frontend Transport service

Note: The Microsoft article contains additional steps to 'Uninstall third-party agents', this is not required for PureMessage for Microsoft Exchange.

Enable the PureMessage transport agents

If you have previously disabled the PureMessage Transport agents to workaround this issue then you will need to enable them after running the Microsoft PowerShell script.

  1. Open the Exchange Management Shell
  2. Run the below commands:

    Enable-TransportAgent PmE15Protocol -TransportService FrontEnd

    Enable-TransportAgent PmE15Protocol -TransportService Hub

    Enable-TransportAgent PmE15Transport -TransportService Hub

  3. Restart the Microsoft Exchange Transport service

Related Information Installation fails on Exchange servers which have been updated to Exchange 2013 Service Pack 1

 
If you need more information or guidance, then please contact technical support.

Rate this article

Very poor Excellent

Comments