Sophos Anti-Virus for Linux / Unix: Could not load module libz.a

  • Article ID: 117545
  • Updated: 10 Oct 2013

Issue

When installing Sophos Anti-Virus version 9.1.x or below the following error may be encountered:

Dependent module libz.a(libz.so.1) could not be loaded.
Could not load module libz.a(libz.so.1).
System error: No such file or directory

First seen in

Sophos Anti-Virus for Unix
Sophos Anti-Virus for Linux

Operating systems
Linux / Unix


What To Do

The libz compression library must be available in order to install Sophos Anti-Virus.  If the 'zlib' package has been removed, please install 'zlib' in order to run Sophos Anti-Virus.

On 64-bit operating systems the 32 bit 'zlib' package must be installed.  
NOTE:  Some 64-bit operating systems provide a package of 32-bit libraries for compatibility with 32-bit applications.  For example, on Ubuntu we recommend to install the 'ia32-libs' package, and it's dependencies.

 
If you need more information or guidance, then please contact technical support.

Rate this article

Very poor Excellent

Comments