During an upgrade of Sophos Anti-Virus for Linux version 9 you cannot call and run savdstatus

  • Article ID: 121284
  • Updated: 08 Aug 2014

Issue

During an upgrade of Sophos Anti-Virus for Linux version 9, you cannot call and run savdstatus.

This can occur during any upgrade, either a minor version (9.7.0 to 9.7.1) or a major version (9.6.1 to 9.7.0) and is an issue for all versions of SAV for Linux v9.

If you are using scripts or monitoring the system to check the status of protection, during the upgrade errors similar to the following may be reported on screen or in the script log files if calling from a script:

Traceback (most recent call last):
File "savdstatus.py", line 18, in <module>
ImportError: No module named Encoding

First seen in


Sophos Anti-Virus for Linux

What To Do

You can safely ignore the error messages.

Your protection is not compromised by this issue, and once the upgrade has completed the command can be run without issue.

 
If you need more information or guidance, then please contact technical support.

Rate this article

Very poor Excellent

Comments